Outbound SEPA Payment Issue
Incident Report for Monese Status
Resolved
This incident has been resolved.
Posted May 19, 2022 - 15:54 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 19, 2022 - 15:23 BST
Update
We are continuing to work on a fix for this issue. We're seeing improvement in making outbound SEPA payments but there may be further delays in beneficiaries receiving these payments.
Posted May 19, 2022 - 13:10 BST
Identified
Our partner has identified the issue and a fix is being implemented. We've seen some improvement in making outbound SEPA payments but there may be further delays in beneficiaries receiving these payments.
Posted May 18, 2022 - 20:31 BST
Investigating
Our partner is investigating an issue where customers are unable to make outbound SEPA payments. We'll continue to provide further updates on this issue as it progresses.
Posted May 18, 2022 - 14:57 BST
This incident affected: Outgoing transfers.