Issue affecting email verificatioin

Incident Report for Monese Status

Resolved

This incident has been resolved.
Posted Oct 09, 2024 - 09:55 BST

Investigating

We are currently investigating an issue which is preventing customers from verifying their email address on their Monese application.
Posted Oct 09, 2024 - 08:58 BST
This incident affected: Account opening.