Outgoing International payments degraded service
Incident Report for Monese Status
Resolved
This incident has been resolved.
Posted Sep 04, 2024 - 07:54 BST
Investigating
One of our partners is experiencing issues and due to that, there might be issues with your outgoing international payments.

We thank you for your patience while we resolve this issue, and we’ll update this page as soon as we can.
Posted Sep 03, 2024 - 21:05 BST
This incident affected: Outgoing transfers.