Issue with card payments
Incident Report for Monese Status
Resolved
This incident has been resolved.
Posted May 10, 2022 - 12:10 BST
Identified
We've identified the issue and we're working on a fix.
Posted May 09, 2022 - 20:00 BST
Update
We are continuing to investigate this issue.
Posted May 09, 2022 - 19:18 BST
Investigating
One of our service partners has reported an issue affecting the card payments, cash withdrawals and incoming transfers. We’re working to identify the cause and resolve this quickly. We’ll update here once we have further information.
Posted May 09, 2022 - 17:40 BST
This incident affected: Card payments, ATM withdrawals, and Incoming transfers.