Issue with Customer Support phone line performance

Incident Report for Monese Status

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 07:26 BST

Identified

While one of our technical partners makes some improvements, you may notice interruptions while trying to call us.

We thank you for your patience while we resolve this issue, and we’ll update this page as soon as we can.
Posted Oct 20, 2025 - 18:06 BST
This incident affected: Account help and support.