Issue with account opening
Incident Report for Monese Status
Resolved
This incident has now been resolved.
Posted Dec 02, 2020 - 13:13 GMT
Monitoring
Our partner has fixed the issue and we're continuing to monitor the results.
Posted Dec 02, 2020 - 09:48 GMT
Investigating
We’re currently investigating a technical issue with one of our partners, which is affecting account opening for some customers. If you already have a Monese account, you won’t be affected. We’re working to fix this as soon as possible.
Posted Dec 02, 2020 - 08:27 GMT
This incident affected: Account opening.