Delay in SEPA Eur payments.
Incident Report for Monese Status
Resolved
This incident has been resolved.
Posted Feb 09, 2024 - 10:10 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 08, 2024 - 14:49 GMT
Investigating
We’re experiencing a delay in processing SEPA EUR Payments. Viewing Account balance might also be affected.
We thank you for your patience while we resolve this issue.
Posted Feb 08, 2024 - 11:14 GMT
This incident affected: Outgoing transfers and Incoming transfers.