Linking your device to Monese app
Incident Report for Monese Status
Resolved
This incident has been resolved.
Posted Jul 29, 2024 - 12:36 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 29, 2024 - 12:32 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 29, 2024 - 12:25 BST
Investigating
We’re experiencing an issue that’s impacting linking your device to your Monese app.

We thank you for your patience while we resolve this issue, and we’ll update this page as soon as we can.
Posted Jul 29, 2024 - 12:06 BST
This incident affected: Monese app.