Cash Advance not operational

Incident Report for Monese Status

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 18:56 GMT

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 18, 2025 - 14:18 GMT

Investigating

Due to Cloudflare's outage, our service provider is having issues that are impacting our Cash Advance service.

We apologise for the inconvenience this might cause you, and we will be updating this page accordingly
Posted Nov 18, 2025 - 14:18 GMT