Duplicated card payments

Incident Report for Monese Status

Resolved

This incident has been resolved.
Posted Oct 07, 2022 - 07:21 BST

Update

We are continuing to monitor for any further issues.
Posted Oct 06, 2022 - 13:53 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 06, 2022 - 13:53 BST

Update

We are continuing to work on a fix for this issue.
Posted Oct 06, 2022 - 12:56 BST

Identified

Unfortunately, some card transactions made from the 4th to the 6th of October were processed twice.

We thank you for your patience while we resolve this issue, and we’ll update this page as soon as possible.
Posted Oct 06, 2022 - 12:56 BST
This incident affected: Card payments.