UK faster payments are delayed
Incident Report for Monese Status
Resolved
This incident has been resolved.
Posted Nov 06, 2023 - 09:27 GMT
Identified
The issues has been identified and a fix has been implemented. The pending payments will be processed on Monday (6.10). Thank you for your patience.
Posted Nov 04, 2023 - 17:58 GMT
Investigating
We’re experiencing a problem with UK Faster Payments at the moment. Your payments might be delayed.

We thank you for your patience while they resolve this issue, and we’ll update this page as soon as we can.
Posted Nov 04, 2023 - 15:55 GMT