Partner Service Outage
Incident Report for Monese Status
Resolved
We can confirm that this issue has been resolved and service has returned to normal.
Posted Oct 10, 2019 - 11:04 BST
Investigating
One of our technical partners has been experiencing a service outage, which affected some customers’ access to the Monese app. We are working to identify the issue and resolve this as quickly as possible. We will update this page once we have further updates.
Posted Oct 10, 2019 - 10:46 BST
This incident affected: Monese app, Account opening, and Outgoing transfers.