We will be undergoing scheduled maintenance during this time.
Posted Apr 16, 2026 - 08:41 BST
Scheduled
Our UK banking partner is performing scheduled maintenance affecting the inbound and outbound UK Faster Payments. During the specified period, all Faster Payments OUT will be queued and sent once the maintenance is completed. This does not disrupt Monese to Monese payments, nor card transactions.
Posted Apr 16, 2026 - 08:40 BST
This scheduled maintenance affects: Outgoing transfers.