Monese app performance degraded

Incident Report for Monese Status

Resolved

The incident has been resolved, and our team is currently working to mitigate and reimburse failed payments.
Posted Feb 13, 2026 - 12:10 GMT

Update

We are continuing to monitor for any further issues.
Posted Feb 12, 2026 - 13:44 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 12, 2026 - 13:41 GMT

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 12, 2026 - 12:41 GMT

Update

We are continuing to monitor for any further issues.
Posted Feb 12, 2026 - 11:49 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 12, 2026 - 11:46 GMT

Update

We are continuing to work on a fix for this issue.
Posted Feb 12, 2026 - 09:57 GMT

Update

We are continuing to work on a fix for this issue.
Posted Feb 12, 2026 - 09:55 GMT

Identified

The Monese app is temporarily unavailable. Card payments and cash operations will still work.

We thank you for your patience while we resolve this issue, and we’ll update this page as soon as we can.
Posted Feb 12, 2026 - 08:16 GMT
This incident affected: Monese app, Account opening, Card payments, Outgoing transfers, Incoming transfers, Card top-ups, Cash top-ups, and Account help and support.