Degraded performance with phone and email support
Incident Report for Monese Status
Resolved
This incident has now been resolved.
Posted Sep 09, 2020 - 19:46 BST
Monitoring
Our supplier has issued a fix and we are seeing normal service resume. We will continue to monitor the results
Posted Sep 09, 2020 - 16:40 BST
Investigating
Our phone and email support is not fully operational at the moment, due to an outage with one of our suppliers. Please contact the Support team via in-app chat in the meantime
Posted Sep 09, 2020 - 13:37 BST
This incident affected: Account help and support.