Adding new payees for SEPA payments temporarily unavailable
Incident Report for Monese Status
Resolved
This incident has been resolved.
Posted Oct 01, 2023 - 19:07 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 01, 2023 - 18:40 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 01, 2023 - 18:36 BST
Investigating
We’re experiencing minor technical issues with our IBAN validation partner, which means it’s not possible to add new payees for SEPA payments at the moment. Payments to existing payees will still work.


We thank you for your patience while we resolve this issue, and we’ll update this page as soon as we can.
Posted Oct 01, 2023 - 17:40 BST
This incident affected: Outgoing transfers.