Paysafe cash deposits in Ireland are not working

Incident Report for Monese Status

Resolved

The maintenance is over.
Posted Feb 26, 2024 - 13:14 GMT

Update

We are continuing to investigate this issue.
Posted Feb 22, 2024 - 14:54 GMT

Investigating

Because of a partner service outage, we’re experiencing issues in processing Paysafe cash top-ups.

We thank you for your patience while we resolve this issue, and we’ll update this page as soon as we can.
Posted Feb 22, 2024 - 08:49 GMT
This incident affected: Cash top-ups.