Incoming SEPA payments

Incident Report for Monese Status

Resolved

This incident has been resolved.
Posted May 19, 2026 - 11:49 BST

Identified

The issue has been identified and a fix is being implemented.
Posted May 15, 2026 - 18:52 BST

Investigating

Due to a third-party processing issue, today’s SEPA payment processing window was missed. Payments expected today will be processed on the next available processing cycle.
Posted May 15, 2026 - 18:51 BST
This incident affected: Incoming SEPA payments.