Monese app performance degraded
Incident Report for Monese Status
Resolved
This incident has been resolved.
Posted Jul 28, 2022 - 10:20 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2022 - 09:57 BST
Investigating
We’re experiencing an issue that’s causing the Monese app to respond slowly or not at all for some customers. Card payments and cash operations will still work.

We thank you for your patience while we resolve this issue, and we’ll update this page as soon as we can.
Posted Jul 28, 2022 - 09:27 BST
This incident affected: Monese app.