Degradation on multiple services with our partner
Incident Report for Monese Status
Resolved
This incident has been resolved.
Posted Mar 23, 2024 - 10:01 GMT
Monitoring
A fix has been implemented, and we are monitoring the results.
Posted Mar 23, 2024 - 09:16 GMT
Update
We are continuing to investigate this issue.
Posted Mar 23, 2024 - 09:14 GMT
Investigating
One of our technical partners is experiencing multiple service degradations, affecting our Monese services. Please note that paying with card or ATM withdrawals might be affected. We’re working to identify and resolve the issue as quickly as possible. We’ll update this page once we have further information.
Posted Mar 23, 2024 - 07:50 GMT
This incident affected: Card payments and ATM withdrawals.