Incorrect Fee Displayed and Charged for EUR SEPA Transfers

Incident Report for Monese Status

Resolved

This incident has been resolved.
Posted Nov 13, 2025 - 14:09 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 12, 2025 - 15:16 GMT

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 12, 2025 - 10:32 GMT

Investigating

We’ve identified an issue where some customers may have been charged an incorrect fee for outgoing EUR transfers. Our team is investigating and working to correct the configuration.

If you were affected, any overcharges will be refunded automatically once the issue is resolved.

We thank you for your patience while we resolve this issue, and we’ll update this page as soon as we can.
Posted Nov 12, 2025 - 10:13 GMT
This incident affected: Outgoing transfers.