Issue with PayPoint top-ups
Incident Report for Monese Status
Resolved
This incident has been resolved.
Posted Feb 20, 2024 - 14:24 GMT
Investigating
We're experiencing a technical issue with one of our partners, which is affecting cash top-ups at PayPoint locations in the UK. We're working with them to investigate this, and we'll update this page as soon as we know more.
Posted Feb 12, 2024 - 10:14 GMT
This incident affected: Cash top-ups.