Card services disruption

Incident Report for Monese Status

Resolved

This incident has been resolved.
Posted May 15, 2026 - 13:26 BST

Update

We are continuing to monitor for any further issues.
Posted May 15, 2026 - 13:16 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 15, 2026 - 13:16 BST

Identified

The issue has been identified and a fix is being implemented.
Posted May 15, 2026 - 13:11 BST

Investigating

Due to an issue with one of our partners, some card services are currently impacted.

At the moment, some customers may experience issues with:

Card payments
Wallet payments (Apple Pay / Google Pay)
Cash withdrawals

Our team is working with our partner to resolve this as quickly as possible. We apologize for the inconvenience and will share updates here as soon as we have more information.
Posted May 15, 2026 - 13:07 BST
This incident affected: Card payments and ATM withdrawals.