Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 18, 2025 - 04:00 BST
Scheduled
On August 18, our UK banking partner will be performing scheduled maintenance. Any inbound UK Faster Payments made during this maintenance time will be held and completed after the maintenance is finished. Any outbound Faster Payments will be stopped. Confirmation of Payee will be unavailable during the maintenance. Monese-to-Monese payments and card transactions will still be operational.
We thank you for your patience while we resolve this issue, and we’ll update this page as soon as we can.
Posted Aug 14, 2025 - 10:54 BST
This scheduled maintenance affected: Outgoing transfers and Incoming transfers.