Issue with account opening
Incident Report for Monese Status
Resolved
The issue has been fixed and account opening is fully operational.
Posted Mar 08, 2021 - 11:57 GMT
Investigating
One of our technical partners is experiencing an outage, which is affecting the opening of new Monese accounts. We’re working to identify the issue and resolve this as quickly as possible. We’ll update this page once we have further information.
Posted Mar 08, 2021 - 09:18 GMT
This incident affected: Account opening.