Post Office Service - Temporarily Unavailable

Incident Report for Monese Status

Resolved

This incident has been resolved.
Posted Apr 29, 2026 - 08:21 BST

Identified

Due to a partner service outage, Post Office deposits are currently unavailable.
Posted Apr 28, 2026 - 18:42 BST
This incident affected: Cash top-ups.