Issue affecting RON transfers
Incident Report for Monese Status
Resolved
This incident has been resolved.
Posted Jun 15, 2022 - 20:54 BST
Investigating
Our partner is investigating an issue affecting local RON transfers. We’ll continue to provide further updates on this issue as it progresses.
Posted Jun 15, 2022 - 17:03 BST
This incident affected: Outgoing transfers and Incoming transfers.