App login issues due to partner technical difficulties
Incident Report for Monese Status
Resolved
App login issues have now been completely resolved. Once again we apologise for any inconvenience caused.
Posted Aug 23, 2019 - 18:23 BST
Investigating
We are experiencing a problem with Monese App login, this is due to our banking partner facing technical difficulties. All stakeholders involved are currently investigating this to resolve the issue ASAP. Apologies for any inconvenience.
Posted Aug 23, 2019 - 16:50 BST
This incident affected: Monese app.