Issue with account access
Incident Report for Monese Status
Resolved
This incident has been resolved.
Posted Jun 10, 2022 - 14:50 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2022 - 14:25 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 10, 2022 - 13:31 BST
Investigating
We are currently investigating the issue related to account being temporarily blocked. We’re working to identify the issue and resolve this as quickly as possible. We’ll update this page once we have further information.
Posted Jun 10, 2022 - 13:16 BST
This incident affected: Monese app, Card payments, ATM withdrawals, Outgoing transfers, Incoming transfers, Card top-ups, and Cash top-ups.